Paperwork Outage
Incident Report for Solvhealth
Resolved
We have released a fix and are seeing improvements for patients. We are still actively monitoring the situation and will let you know if we have any further updates! Thank you for your patience.
Posted Sep 25, 2024 - 17:48 EDT
Update
We're experiencing intermittent issues with patients navigating through our paperwork. We are intensively working on resolution of this issue. We will keep you posted as we have more updates. In the meantime, if a patient experiences a "rain man" when navigating paperwork, please collect their information at the front desk.
Posted Sep 25, 2024 - 16:33 EDT
Investigating
We're experiencing intermittent issues with patients navigating through our paperwork. We are intensively working on resolution of this issue. We will keep you posted as we have more updates. In the meantime, if a patient experiences a "rain man" when navigating paperwork, please collect their information at the front desk.
Posted Sep 25, 2024 - 13:30 EDT
This incident affected: Solv Patient App (Website) and Solv Provider Dashboard (Website).